using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[ \t]*include[ \t]+(\""|<)([^>\""]+)(?:\""|>)";
string input = @"#include ""stdafx.h""
#include <iostream>
# include <avr32/uc3c0128c.h>
#include ""../my_path/header.h""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}