import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#[ \\t]*include[ \\t]+(\\\"|<)([^>\\\"]+)(?:\\\"|>)";
final String string = "#include \"stdafx.h\"\n"
+ "#include <iostream>\n"
+ "# include <avr32/uc3c0128c.h>\n"
+ "#include \"../my_path/header.h\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}