re = /#[ \t]*include[ \t]+(\"|<)([^>\"]+)(?:\"|>)/m
str = '#include "stdafx.h"
#include <iostream>
# include <avr32/uc3c0128c.h>
#include "../my_path/header.h"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end