#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "use\s+\S+(*SKIP)(*F)|\w++(?=::\w+)|(?<!^)\G::\K\w+"
Local $sString = "first::second::third::fourth" & @CRLF & _
"use first::second::third::fourth" & @CRLF & _
"first second::third use fourth::fifth"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")