const regex = /use\s+\S+(*SKIP)(*F)|\w++(?=::\w+)|(?<!^)\G::\K\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('use\\s+\\S+(*SKIP)(*F)|\\w++(?=::\\w+)|(?<!^)\\G::\\K\\w+', 'g')
const str = `first::second::third::fourth
use first::second::third::fourth
first second::third use fourth::fifth`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}