$re = '/use\s+\S+(*SKIP)(*F)|\w++(?=::\w+)|(?<!^)\G::\K\w+/';
$str = 'first::second::third::fourth
use first::second::third::fourth
first second::third use fourth::fifth';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);