using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"use\s+\S+(*SKIP)(*F)|\w++(?=::\w+)|(?<!^)\G::\K\w+";
string input = @"first::second::third::fourth
use first::second::third::fourth
first second::third use fourth::fifth";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}