import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "use\\s+\\S+(*SKIP)(*F)|\\w++(?=::\\w+)|(?<!^)\\G::\\K\\w+";
final String string = "first::second::third::fourth\n"
+ "use first::second::third::fourth\n"
+ "first second::third use fourth::fifth";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}