package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Step.*)(Description.*)`)
var str = `/**
* @company-gherkin: Step: go to the list. Description: Navigates to the list.
*/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}