// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Step.*)(Description.*)").unwrap();
let string = "/**
* @company-gherkin: Step: go to the list. Description: Navigates to the list.
*/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}