$re = '/(Step.*)(Description.*)/';
$str = '/**
* @company-gherkin: Step: go to the list. Description: Navigates to the list.
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);