#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{5}([-]|\s*)?(\d{4})?$"
Local $sString = "12345" & @CRLF & _
"12345-6789" & @CRLF & _
"12345 1234" & @CRLF & _
"123451234" & @CRLF & _
"12345 1234" & @CRLF & _
"12345 1234" & @CRLF & _
"1234512341" & @CRLF & _
"123451"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")