using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{5}([-]|\s*)?(\d{4})?$";
string input = @"12345
12345-6789
12345 1234
123451234
12345 1234
12345 1234
1234512341
123451";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}