// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{5}([-]|\s*)?(\d{4})?$").unwrap();
let string = "12345
12345-6789
12345 1234
123451234
12345 1234
12345 1234
1234512341
123451";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}