import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{5}([-]|\\s*)?(\\d{4})?$";
final String string = "12345\n"
+ "12345-6789\n"
+ "12345 1234\n"
+ "123451234\n"
+ "12345 1234\n"
+ "12345 1234\n"
+ "1234512341\n"
+ "123451";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}