re = /^\d{5}([-]|\s*)?(\d{4})?$/m
str = '12345
12345-6789
12345 1234
123451234
12345 1234
12345 1234
1234512341
123451'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end