#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bMTG-(?:LR )?(\d+(?: / \d+)?)\b"
Local $sString = "MTG-2022039036 MTG" & @CRLF & _
"MTG-LR 3136 / 130 MTG " & @CRLF & _
"MTG-LR 201260 / 9046 ASSIGN" & @CRLF & _
"MTG-2021063349 MTG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")