re = /\bMTG-(?:LR )?(\d+(?: \/ \d+)?)\b/m
str = 'MTG-2022039036 MTG
MTG-LR 3136 / 130 MTG
MTG-LR 201260 / 9046 ASSIGN
MTG-2021063349 MTG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end