// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bMTG-(?:LR )?(\d+(?: / \d+)?)\b").unwrap();
let string = "MTG-2022039036 MTG
MTG-LR 3136 / 130 MTG
MTG-LR 201260 / 9046 ASSIGN
MTG-2021063349 MTG";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}