import re
regex = re.compile(r"\bMTG-(?:LR )?(\d+(?: / \d+)?)\b", flags=re.MULTILINE)
test_str = ("MTG-2022039036 MTG\n"
"MTG-LR 3136 / 130 MTG \n"
"MTG-LR 201260 / 9046 ASSIGN\n"
"MTG-2021063349 MTG")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")