import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bMTG-(?:LR )?(\\d+(?: / \\d+)?)\\b";
final String string = "MTG-2022039036 MTG\n"
+ "MTG-LR 3136 / 130 MTG \n"
+ "MTG-LR 201260 / 9046 ASSIGN\n"
+ "MTG-2021063349 MTG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}