#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[+-]?[0-9][0-9]*(\.[0-9]*)?\b"
Local $sString = "twentyseven27" & @CRLF & _
"27, 56, -151.43, +15350.16f, (the boundary avoids to accept the fractional part)" & @CRLF & _
"e37, e+25.42, (the + acts as a boundary, so it scans the number correctly)" & @CRLF & _
"e25.42 (look at this... we should avoid this)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")