import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[+-]?[0-9][0-9]*(\\.[0-9]*)?\\b";
final String string = "twentyseven27\n"
+ "27, 56, -151.43, +15350.16f, (the boundary avoids to accept the fractional part)\n"
+ "e37, e+25.42, (the + acts as a boundary, so it scans the number correctly)\n"
+ "e25.42 (look at this... we should avoid this)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}