import re
regex = re.compile(r"\b[+-]?[0-9][0-9]*(\.[0-9]*)?\b", flags=re.MULTILINE)
test_str = ("twentyseven27\n"
"27, 56, -151.43, +15350.16f, (the boundary avoids to accept the fractional part)\n"
"e37, e+25.42, (the + acts as a boundary, so it scans the number correctly)\n"
"e25.42 (look at this... we should avoid this)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")