$re = '/\b[+-]?[0-9][0-9]*(\.[0-9]*)?\b/m';
$str = 'twentyseven27
27, 56, -151.43, +15350.16f, (the boundary avoids to accept the fractional part)
e37, e+25.42, (the + acts as a boundary, so it scans the number correctly)
e25.42 (look at this... we should avoid this)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);