# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z]?)([0-9]+(\.[0-9]*)?)|([+-][0-9]+(\.[0-9]*)?)/<$1, $2, $4>/gm;t' <<< "twentyseven27 (this is rejected, as there's something in group 1)
27, 56, -151.43, +15350.16f, (all accepted, first two in group 2, last two in group 4)
e37, e+25.42, (first rejected, last accepted --- group 4)
e25.42 (rejected)
"