const regex = /([a-zA-Z]?)([0-9]+(\.[0-9]*)?)|([+-][0-9]+(\.[0-9]*)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]?)([0-9]+(\\.[0-9]*)?)|([+-][0-9]+(\\.[0-9]*)?)', 'gm')
const str = `twentyseven27 (this is rejected, as there's something in group 1)
27, 56, -151.43, +15350.16f, (all accepted, first two in group 2, last two in group 4)
e37, e+25.42, (first rejected, last accepted --- group 4)
e25.42 (rejected)
`;
const subst = `<$1, $2, $4>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);