package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z]?)([0-9]+(\.[0-9]*)?)|([+-][0-9]+(\.[0-9]*)?)`)
var str = `twentyseven27 (this is rejected, as there's something in group 1)
27, 56, -151.43, +15350.16f, (all accepted, first two in group 2, last two in group 4)
e37, e+25.42, (first rejected, last accepted --- group 4)
e25.42 (rejected)
`
var substitution = "<$1, $2, $4>"
fmt.Println(re.ReplaceAllString(str, substitution))
}