# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z]?)([0-9]+(\.[0-9]*)?)|([+-][0-9]+(\.[0-9]*)?)"
test_str = ("twentyseven27 (this is rejected, as there's something in group 1)\n"
"27, 56, -151.43, +15350.16f, (all accepted, first two in group 2, last two in group 4)\n"
"e37, e+25.42, (first rejected, last accepted --- group 4)\n"
"e25.42 (rejected)\n")
subst = "<$1, $2, $4>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.