using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]?)([0-9]+(\.[0-9]*)?)|([+-][0-9]+(\.[0-9]*)?)";
string substitution = @"<$1, $2, $4>";
string input = @"twentyseven27 (this is rejected, as there's something in group 1)
27, 56, -151.43, +15350.16f, (all accepted, first two in group 2, last two in group 4)
e37, e+25.42, (first rejected, last accepted --- group 4)
e25.42 (rejected)
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}