using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"case_when\([^(]*%in%(*SKIP)(*FAIL)|[^(]*%in%";
string input = @"a %in% c('b', 'e')
case_when(a %in% c('b', 'e'))
hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}