re = /case_when\([^(]*%in%(*SKIP)(*FAIL)|[^(]*%in%/m
str = 'a %in% c(\'b\', \'e\')
case_when(a %in% c(\'b\', \'e\'))
hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end