import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "case_when\\([^(]*%in%(*SKIP)(*FAIL)|[^(]*%in%";
final String string = "a %in% c('b', 'e')\n"
+ "case_when(a %in% c('b', 'e'))\n"
+ "hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}