$re = '/case_when\([^(]*%in%(*SKIP)(*FAIL)|[^(]*%in%/m';
$str = 'a %in% c(\'b\', \'e\')
case_when(a %in% c(\'b\', \'e\'))
hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);