using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"background:url\(([^\)]+)\)";
string input = @"background:url(//somedomaine.com/annonces/103028/large.jpg) no-repeat center center
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}