$re = '/background:url\(([^\)]+)\)/m';
$str = 'background:url(//somedomaine.com/annonces/103028/large.jpg) no-repeat center center
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);