package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)background:url\(([^\)]+)\)`)
var str = `background:url(//somedomaine.com/annonces/103028/large.jpg) no-repeat center center
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}