// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)background:url\(([^\)]+)\)").unwrap();
let string = "background:url(//somedomaine.com/annonces/103028/large.jpg) no-repeat center center
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}