re = /background:url\(([^\)]+)\)/m
str = 'background:url(//somedomaine.com/annonces/103028/large.jpg) no-repeat center center
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end