# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b\w+)( \1\b){1,}/$1/gm;t' <<< "n n n n north na na na na south n n n n east n n n n west"