re = /(\b\w+)( \1\b){1,}/m
str = 'n n n n north na na na na south n n n n east n n n n west'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result