using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w+)( \1\b){1,}";
string substitution = @"$1";
string input = @"n n n n north na na na na south n n n n east n n n n west";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}