const regex = /(\b\w+)( \1\b){1,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\w+)( \\1\\b){1,}', 'gm')
const str = `n n n n north na na na na south n n n n east n n n n west`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);