use strict;
my $str = 'n n n n north na na na na south n n n n east n n n n west';
my $regex = qr/(\b\w+)( \1\b){1,}/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";