#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(ht{2}ps?:\/{2})?(w{3}.)?regex101\.com\/r\/\w+$"
Local $sString = "http://regex101.com/r/fW0vZ2" & @CRLF & _
"https://regex101.com/r/mH1fN5" & @CRLF & _
"regex101.com/r/121fa5" & @CRLF & _
"www.regex101.com/r/mH1fN5" & @CRLF & _
"http://www.regex101.com/r/fW0vZ2" & @CRLF & _
"https://www.regex101.com/r/mH1fN5" & @CRLF & _
"http://www.regex101.com/r/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")