using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(ht{2}ps?:\/{2})?(w{3}.)?regex101\.com\/r\/\w+$";
string input = @"http://regex101.com/r/fW0vZ2
https://regex101.com/r/mH1fN5
regex101.com/r/121fa5
www.regex101.com/r/mH1fN5
http://www.regex101.com/r/fW0vZ2
https://www.regex101.com/r/mH1fN5
http://www.regex101.com/r/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}