// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(ht{2}ps?:\/{2})?(w{3}.)?regex101\.com\/r\/\w+$").unwrap();
let string = "http://regex101.com/r/fW0vZ2
https://regex101.com/r/mH1fN5
regex101.com/r/121fa5
www.regex101.com/r/mH1fN5
http://www.regex101.com/r/fW0vZ2
https://www.regex101.com/r/mH1fN5
http://www.regex101.com/r/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}