re = /^(ht{2}ps?:\/{2})?(w{3}.)?regex101\.com\/r\/\w+$/m
str = 'http://regex101.com/r/fW0vZ2
https://regex101.com/r/mH1fN5
regex101.com/r/121fa5
www.regex101.com/r/mH1fN5
http://www.regex101.com/r/fW0vZ2
https://www.regex101.com/r/mH1fN5
http://www.regex101.com/r/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end