package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(ht{2}ps?:\/{2})?(w{3}.)?regex101\.com\/r\/\w+$`)
var str = `http://regex101.com/r/fW0vZ2
https://regex101.com/r/mH1fN5
regex101.com/r/121fa5
www.regex101.com/r/mH1fN5
http://www.regex101.com/r/fW0vZ2
https://www.regex101.com/r/mH1fN5
http://www.regex101.com/r/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}