import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(ALLEE|ANSE|AVENUE|BOULEVARD|CARREFOUR|CHAUSSEE|CHEMIN|CITE|CLOS|COTE|COUR|COURS|DEGRE|DESCENTE|DREVE|ESCOUSSIERE|ESPLANADE|GAFFE|GRAND-ROUTE|IMPASSE|LIAISON|MAIL|MONTEE|PASSAGE|PLACE|PLACETTE|PONT|PROMENADE|QUAI|RESIDENCE|RANG|RAMPE|ROND-POINT|ROUTE|RUE|RUELLE|SENTE|SENTIER|SQUARE|TRABOULE|TRAVERSE|VENELLE|VILLA|VOIE|BERGE|DIGUE|CUL-DE-SAC|ESCALIER|GIRATOIRE|JARDIN|PARVIS|PASSERELLE)\\b";
final String string = "ALLEE RUE ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}